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Research Note-taking
If you write papers based on research for any length of time you will probably accumulate a large number of
notes that you may or may not have some way of organizing for future reference. By the same token, your
research output will also contain material, often different from your original notes, that could usefully be referred
to in future research.
A growing number of apps offer a variety of ways to organize your research notes. A number of these have nice
features and many are free and open-source. I have listed some of them in the Appendix. However a simple
solution is to make use of your reference management app if it includes features for good note-taking.

Zotero Features
•

Open-source and cross-platform. Works very well on Linux, Mac, and Windows.

•

Integration with LibreOffice, LyX, Word, and Google Docs.

•

Automatically senses research on the web. One-click download.

•

Tag suggestions from existing list; tag pane to find related items.

•

Manual addition of related items (links between notes and backlinks).

•

Foldable collections, nested collections, and sub-collections of parent items.

•

Multiple criteria for sorting standalone notes or along with parent items.

•

Excellent advanced search including full text of pdfs with Zotxt plugin, and smart saved searches.

•

Zotero is highly customizable and has a number of high quality, very useful add-ons or plug-ins, especially
Zotfile,1 Zotxt, Zutilo, Report Customizer and BetterBibTeX.

•

Group library (incl. Notes and, optionally, files) can be created by drag and drop from your Library or
collections and shared with collaborators using Zotero.org’s free service.
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•

Database (and notes) can be synced across devices using your account on Zotero.org’s free server.

•

Import and export entire database to and from a wide range of formats.

•

Excellent documentation and support, and continuous development.2

Many of the homepages for these add-ons/plug-ins are still set up for the old Zotero which was itself a plug-in for
Firefox. To correctly download the add-on right-click on the Download button and select “Save Link As ...” and save
the .xpi to your Downloads folder. Then follow the install instructions for installing to Zotero 5 Standalone.
Zotero is supported by a nonprofit organization, the Corporation for Digital Scholarship, which develops software for
researchers.

Zotero as a Note-taking application
Zotero is a free and open-source bibliographic reference management and citation app that was developed in
part with the motivation to give researchers greater freedom to choose the tools they write with. 3 It performs
better in most respects than proprietary, expensive bibliographic apps (D’Angelo et al., 2017, Ch.14).4 Zotero is
also a good way to organize your research notes and bibliographic sources together.
Some requirements that enable efficient note-taking 5 are atomicity,6 unique naming, links to other notes, and
tags or keywords. You should also be able to find notes easily and organize them usefully. With Zotero you can
set up a workflow to satisfy these requirements and more.

Workflows
Quick Note-taking
Make a quick idea note when you don’t want to interrupt your work flow.
1. For quick standalone notes: Open a new note in Zotero: Cmd+Shift+O on Mac or Ctrl+Shift+O on
Linux or Windows, and type in the right-hand note editor pane. 7 The note is saved automatically.8
2. Go back to elaborate on your notes later in the day when you are ready to add more information. The
next section has suggestions on adding information to make your notes more useful for your research.
3. Set a regular time to read through and analyse your idea notes.9 Questions and associations that arise
will give you ideas for further research. New question notes can be added as children to the idea notes.
Annotation Notes
When you install Zotero, the plug-in to integrate with your word processor should be added automatically.10 You
will want to install the connector for your browser, and then you can add reference items from the web to
Zotero. If the citation’s pdf is open-access, or you have navigated to its page through your institution’s library
site, the pdf should be attached to your reference item in Zotero’s central pane. Double-clicking the item will
open the pdf in your default pdf reader for reading and annotating.
Preview on Mac, Okular on Linux,11 and Adobe Acrobat Reader on Windows will all provide you with annotation
tools.12 If you are using Preview on Mac, the Tools menu points to the annotation features. 13 Highlights are
extracted14 as attached notes by Zotero’s Zotfile plug-in. In Zotero’s Notes edit pane you can add your summary,
comments, related items and tags to these verbatim highlights.
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For example, Zotero allows portability between word processors while maintaining live citations.
A number of sites list Zotero as note-taking software, but, since it was not specifically designed for that purpose, it does
lack some features that are common in dedicated note-taking apps. In particular, Zotero lacks support for adding
timestamps, reordering items and notes within its collections tree, and exporting notes (and their metadata). My
workflow provides workarounds for these missing features. Zotero's positive features may make up for its drawbacks.
Taking notes in class requires a somewhat different approach from taking notes from readings.
For your database of notes to be most useful, each note should contain the text and metadata of a single idea. Perhaps
two or three sentences. This will allow new connections and patterns between ideas to develop as the database grows.
This blogger also advocates the principle of “autonomy” meaning each note can stand on its own. This seems intuitive.
You can also edit the note in a larger, separate window by clicking the box at the bottom of the note editor.
To make quick note-taking even quicker set Zotero to start at login: System Preferences => Users and Groups => Login
Items. I also set the free and open-source Quicksilver as a login item.
Reviewing your notes will help you retain the information and ideas in long-term memory (Boch & Piolat, 2005)
A good introduction to working with Zotero can be found here.
The instructions in this guide apply to Linux Mint. They should be similar for other environments based on Gnome.
Adobe’s Reader runs on Mac or Windows https://helpx.adobe.com/reader/system-requirements.html. My preferred
reader on Mac is Skim which, although a little quirky, comes with many good options. I have found that comments made
with Skim (using “Add New Anchored Note”) will be extracted as long as the pdf is then exported as pdf “with
embedded notes” (I give it a suffix “N”) and this file is then added to the Zotero item as an attachment. Zotero’s Add
Attachment => Attach Stored Copy of File ... opens a dialog with drop-down at top. Go to Recent Places to find the
folder (it will have a name like JK8HN7IE) and pdf with suffix “N” - highlight it and click “Open” then extract annotations.
I wrote this guide to record my own workflow and I hope it will be useful to others with a similar setup.
To extract: Right-click on the item in Zotero’s central pane, select Manage Attachments => Extract Annotations. This
requires the Zotfile plug-in.

For quick annotation15 notes only the citation of, or link to your reference, and page number is necessary. If you
are annotating a pdf attached to a parent item in Zotero the link to the item already exists. 16 Other information
can be added as indicated below during an “elaboration”17 session.
Note also that researchers have found that long-hand note-taking with pen and paper is valuable for improving
understanding (Steimle et al., 2007).18
1. A summary of the passage quoted is useful, and a good paraphrase. Be clear on what is quoted
verbatim in your notes. Cite the source and include page numbers.
2. Add “tags” or keywords which indicate the general subject, issue etc. directly related to this note. 19
3. Add links to related items in your Zotero database and to related web resources

if any.20

4. Name the note with an appropriate title, hit the Enter key to put a paragraph break after your title, apply
a Heading style to it - I prefer Heading 2 - useful to reorder notes within LibreOffice – point 8 below.
The following points are optional and/or additional to the workflow.
1. To make the best use of notes it is a good practice to separate long notes into small, paragraph sized
ones (plus comments etc.) - If necessary, cut and paste each section of a long note to a new note.
2. I use a template for new notes – See the Appendix for my Annotation_Zettel_Template.txt
and Standalone_Zettel_Template.txt
3. On my Mac I have added an espanso21 text to insert these templates into a note – I just type the letters
“z n t” for the annotation template and “z s t” for the standalone template.
4. If desired, you can add a “note to self” as a Blockquote at end of the note.
5. To maintain portability,22 I prefer to add a unique ID as a prefix to the note’s name.23 Also, because the
dates are not preserved in notes themselves on export, I record the date and time I made each note. 24
My shortcuts25 are on Linux: Shift+Alt+T on Mac: Ctrl+⌘+= I also like to add such a timestamp for
each modification.
6. You have the option to create parent items for standalone notes. 26 In Zotero’s centre menu panel the
first button is “New Item”
Create a “Document” parent item with yourself as
author and then duplicate
it a few times with Zotero’s context menu.
7. A link back to the Zotero
stored pdf can be added to your note even if the note
27
was not extracted from a pdf annotation. These links are automatically included in generated Reports
and can be helpful in the outline stage of writing and can simply be removed in later drafts. Such a link
15 You can also get creative with the way you make notes that refer to a reference source as described here.
16 You can optionally add your own pseudo Citekey. Instead of a Citekey to refer to additional references in your note
simply type @authoryearabbreviatedtitlepg (e.g. @Habermas1985ComAct2p97). This can then be replaced with a live
citation in LibreOffice.
17 On the linked web page scroll down to this image
and read on for suggestions. Standalone notes do not
need to be organized into categories. Better just to
add links (to Related items) and tags.
18 For research reading note-taking is essential. Annotate pdfs as you read with highlights (and anchored margin notes if
these work with your setup). In books I use sticky notes and type up later. Taking “quick notes” is also important
because you need to record your (often valuable but fleeting) ideas as they occur to you.
19 Keywords are best used economically so that they form a useful network. See the section on Tags & Keywords below.
20 In the notes editor “Related” is at the bottom, adding url links is at the top right. I suggest using links in a similar way to
keywords. See the section on Links below.
21 The espanso default.yml file for creating shortcuts is stored at ~/Library/Preferences/espanso/default.yml
22 .. and if your notes are plain-text (see below), as in QOwnNotes - I suggest creating these quick note files with
MacDown or similar on a Mac. For plain-text notes you can use a compact timestamp for unique ID as part of the name
of each note. See scripts in Appendix to integrate this with MacDown on Mac OS X and to use Shift+Alt+D on Linux.
23 See Scripts section in Appendix below.
24 In Zotero it is not totally necessary to add timestamps for creation date and modified date since Zotero keeps track of
these and, similarly, since it uses a database, a unique ID is not strictly needed if you do not plan to export your notes as
plain-text. More on plain-text below.
25 These shortcuts insert the date and time into Zotero’s note editor on my Mac and Linux systems. They will not
necessarily work in other applications.
26 Metadata Related items, and Date added is retained by parent items in reports but not by notes.
27 When you copy and paste an extracted annotation from Zotero the link to the annotated pdf page is clickable.

(which will become active in LibreOffice) to the item in Zotero can also be copied to the clipboard by
right-clicking the item and using Zutilo “Copy select item links.” Or highlight the item and use a
(customizable) shortcut which you can set in Tools => Zutilo preferences. Mine is Shift+W
8. Use Zotero’s customizable Report to create an html export of a note, collection, or notes in a saved
search, which can be copied and pasted as rich text format (.rtf) in LibreOffice writer. The sections can
be rearranged using LibreOffice’s Navigator. You can generate Reports by quick searching for a term
matching a section heading in your paper/thesis.
9. For collaboration use Zotero’s Groups feature.

Tags & Keywords
A certain degree of metacognition is needed when adding a tag or keyword to a note. It is necessary to
consider the purpose of tagging and the purpose of keywords. Tags or keywords added by the software are
indexed to speed searching but keywords in general also point to specific subjects or themes within a research
project, the name of which may not otherwise be included in the text of the note.
Since Zotero uses the single expression “tag” to refer to all types of tag or keyword, for the sake of clarity, I use
“type tags” to refer to tags used for categorization or status of the note or information type and the term
“keyword tag” to refer to descriptive “hashtags” or content tags which give information about the subject matter
of the note.28
The result of a keyword tag search needs to be narrow enough to allow focus but broad enough to show
serendipitous connections. For this reason, always immediately give each note at least one keyword tag, but
avoid keywords which have only peripheral association with the subject matter of the note. When elaborating on
notes add as many appropriate keywords as you like.29
The differentiation between type tags and keyword tags may be clear enough so that a formal distinction is not
necessary. For example, a note which is assigned the tags: “diplomacy” “todo” and “Ottoman Empire” clearly
requires some action by yourself but contains content referring to the subjects: “diplomacy” and “Ottoman
Empire.”30
The Format of Tags and Keywords
If you add your own tags in the text of your note it is sensible to adhere to one of the common conventions for
plain-text syntax. Markdown is perhaps the most common. Its syntax does not use the combination: #keyword
(with no space) so the hash sign “#” is commonly used for tags. Similarly, the combination: %tag is also
available.
Because Zotero’s otherwise excellent advanced search does not distinguish between standalone notes and
attached notes, it may be useful to distinguish between “research” and “idea” notes. For example “Type” tags
with prefix “%%%” are added by my scripts for annotations attached to research sources - %%%annotation
and for standalone notes - %%%cjp - insert your initials for the standalone type tag. Some researchers create
higher level notes using “Index” tags with prefix “%” or “Contents” tags with prefix “%%” for example. 31

28 “Tag” and “Keyword” are used in different ways in different syntaxes. Compare the use of “keyword” in the SGML
Standard (refers to categories) with the reference to content in relation to web pages (Velásquez et al., 2005)
29 See point 4 about half way through this blog post for one researcher’s use of keywords:
https://jostwald.wordpress.com/2012/10/20/an-exciting-note-taking-adventure/
30 Compare the definition of Tag given on the org-mode wiki: https://orgmode.org/worg/org-glossary.html#tag and more
examples of usage at https://sachachua.com/blog/2008/01/tagging-in-org-plus-bonus-code-for-timeclocks-and-tags/
Whether to make a formal distinction between these classes of tag is a matter of personal choice. Researchers in
human or social sciences, however may find tags referring to “method” for example useful when making notes on their
own research (Polonsky et al., 2006)
31 If you use “Index” and/or “Contents” notes add relevant new notes to the appropriate index when you elaborate them.

You can be creative and invent your own tags that convey meaning to you, but have improbable key
combinations.32 Further optional tags, for example, could be !x for important fact, ?x for point to be followed
up, ?! for point in dispute.
In order to avoid duplicates of keywords I try to adhere to some simple rules. For example:
•
•
•

Only proper nouns (Names of specific people, places, etc.) take capitals.
Use common nouns if appropriate, rather than adjectives.
Do not end the keyword with a period (full-stop).

Although keywords and tags are often conflated, their usages have historically developed to serve a variety of
purposes. While keywords have long been used to describe the subject matter of a text or note, the term “tag”
has recently been used for this purpose. However “tag” can also usefully be used to refer to the class or type of
the note.

Links
Links between notes and links to reference sources form a wiki-like network of information that allows the
discovery of connections between ideas and the grouping of ideas according to your chosen themes. Although
full-text search will produce a list of items containing the same term, your handmade links are determined by
associations that have occurred to you at the time of making the note. These associations will be closely related
to the project you are currently working on and may produce links that you would not necessarily recognize from
among the results of a full-text search.
Zotero’s “Related” function makes it simple to insert links to associated items by providing a dialog to search
your whole library by multiple criteria.33
Annotating “Related” links
When annotating links to related items it is desirable to be concise in expressing the idea relevant to the link.
Take a look at how Dan Scheffer annotates his links here.

Searching your Notes – and Everything
The quick search box will find notes to which you have added your own heading if you use "All Fields & Tags" to
search for the heading. Full-text search - “Everything” - requires Full-Text Indexing to be enabled - to search the
contents of (most) attached pdf files.
Tag search can be performed either from the quick search box - "All Fields & Tags" – or by opening the tag
selector at the bottom of the left Zotero pane. Click on the little dot and any existing tags will be shown.
Advanced Search
Zotero's advanced search is a powerful database query search that allows searching on multiple criteria
including “Item Type.” However, since standalone notes are not included in “Item Type” options, this is another
reason for creating parent items for them.
From an advanced search you have the option to create a Saved Search which will be continuously updated.
Saved searches can be used to export items meeting your criteria either by generating a report or using Rightclick Export Saved Search. The latter can be used to produce (among many other formats) a plain-text .bib file
which can be used by other bibliographic software or opened in any text editor.

Generating Reports from Notes
Generating a report is my recommended way of getting multiple notes out of Zotero. Individual notes can simply
be copied and pasted. As suggested above: Use Zotero’s customizable 34 Report to produce an html output of a
32 See, for example, Bernt Hansen’s tags http://doc.norang.ca/org-mode.html#Tags
33 To a large extent this function depends on your deciding upon the associated items because it does not provide
Advanced Search capabilities.
34 https://github.com/retorquere/zotero-report-customizer

note,35selected notes, a collection, or notes in search results or a saved search, which can then be copied and
pasted as rich text format (.rtf) into LibreOffice writer. 36
For example, you can generate a Report by quick searching for a term matching a section heading in your
paper/thesis.
This generates a html report of the notes text with essential metadata from the notes.
The Report includes

•

Parent item as Heading – allowing notes to be rearranged using LibreOffice’s Navigator

•

Link back to the note within Zotero

•

In the case of Zotfile extracted annotations, the date extracted and a link to the page in the pdf.

•

The tags attached to the note(s)

•

External links attached to the note(s)

•

Report does not include Related items attached to the note

•

Report does include Related items attached to the parent item of the note

If you have given your notes headings, the sections can be further rearranged using LibreOffice’s Navigator.

When Parent Item metadata is exported as a table (to include an abstract, for example) convert the table to text
in LibreOffice: Table > Convert > Table to Text > Paragraph

Zotero Collections
Zotero collections do not function in the same way as nodes in an outliner or most note-taking software.
Collections are automatically sorted alphanumerically but do provide a limited way of organizing your research
material thanks to to sub-collections. You can drag any item into a collection or sub-collection to place a link
from the original in the collection. The items remain in place within “My Library.”
An item can be copied to multiple collections and sub-collections. This can be useful for viewing items in
projects or topics, for example. If you import items from your browser or from your filesystem to a specific
collection or drag them to collections from your library they will always also be part of the master index of “My
Library” but will not show up in searches within other collections. This can be used as another way of organizing
and filtering items and notes. Note however the limitation that collections are always sorted by Zotero
alphanumerically.

Maintenance
1. Setup a Zotero.org account and use it to sync your database (also files if limited in number and size.)
2. Make a plain-text backup by exporting “My Library” to BibTeX format including notes (use
BetterBibLaTeX export option and include notes and keep updated). Ideally this .bib file will be stored on
an external hard drive or usb connected to your PC or Mac - and offsite if you have a cloud service.
3. Backup Zotero’s Storage folder once per week on an external hard drive or usb connected to your PC
or Mac (FreeFileSync is good for this – use the “Update” setting – top right) - and offsite if you have a
cloud service with sufficient capacity.
4. Once per month, with Zotero closed, copy the entire Zotero folder to a backup location.
5. If you are on a Mac use TimeMachine for full disk backup.37
35 Using Ctrl+click a subset of notes can be selected.
36 Unfortunately this does not seem to work with Google Docs. You get a similar font size & bold but not a Heading.
37 For added security you can also use SuperDuper. Another good option is the open-source, cross-platform Duplicati.

6. From time to time check that your Zotero add-ons are up to date. Tools => Add-ons =>

Rich-text Format
Zotero’s TinyMCE editor produces rich-text format 38 which can be read by many free and open-source apps,
including word processors LibreOffice Writer, AbiWord, Bean,39 FocusWriter, and Ted;40 and note-taking apps
TiddlyWiki (all platforms), Cherrytree, and TreeLine (Linux and Windows).41
Copying and pasting a note or notes from Zotero to LibreOffice reproduces the heading levels from the note. As
mentioned above this allows reordering of the sections using LibreOffice Writer’s Navigator.
Similarly, copying and pasting a Report generated from multiple notes from Zotero into LibreOffice has the same
result.42

HTML Format
Zotero’s Reports are generated in html format 43 which will be clear when copying and pasting into a plain-text
app like MacDown. A number of word processors are capable of opening, editing and saving HTML documents.
These include the LibreOffice, OpenOffice, Microsoft, Apple, and AbiWord processors. The TinyMCE editor is
another example.
As noted above, copying and pasting from a Zotero Report to LibreOffice, for example, will produce a properly
formatted document that can then be edited as usual, including reordering the sections using Navigator. A
finished document can be saved from LibreOffice in over a dozen formats, including docx, or exported as a PDF
or EPUB.

--|--

RTF was developed and maintained by Microsoft but the company no longer maintains the standard.
Bean 2.4.x is open source.
https://en.wikipedia.org/wiki/Rich_Text_Format
Apple Notes also supports rich text and there is even a free text exporter app available. Both are proprietary though.
If you want to turn this document into multiple plain-text notes one way to do that on Linux or Windows is to Import it
into TreeLine with the option to split into multiple notes at paragraph endings. However, on Mac OS X and Linux this can
also be achieved with the unix utility awk https://stackoverflow.com/questions/53866088/bash-how-to-split-file-onempty-line-with-awk. The cross-platform, open-source app QOwnNotes will also split any imported text into multiple .txt
or .md notes. The context menu has the option “Split note at cursor position” https://www.qownnotes.org
43 HTML standards are proposed by the W3C (World Wide Web Consortium) Web Platform Working Group while the
format is developed by the Web Hypertext Application Technology Working Group (WHATWG).
38
39
40
41
42

Appendix
Scripts
Mac
These are my customized shortcuts.44 See below for script code.
Insert Date and Time: Ctrl+Cmd+T
Insert Unique ID: Crtl+Cmd+U
Open new .md file with unique name: With Quicksilver running: Ctrl+Cmd+W
Create Parent Item - used for standalone notes: Highlight note and Shift+P
No code - This is customized from Zotero's Tools => Zutilo Preferences => Shortcuts

Linux
Insert Unique ID: Shift+Alt+D
Texpander: Ctrl+Space
Insert Timestamp: Shift+Alt+T

Code
Bash scripts begin with #! /bin/sh You can learn more about scripts here.45
The script code below is in Mono typeface (that is what you need to copy and paste into your text editor).
The filename of scripts is above the code in bold and I have indicated after the code the shortcut I gave to each.

Scripts for Linux
Create a new “Scripts” directory within your home directory and use your text editor 46 to save the code for each
script as a text file there.
Make the file executable by either
1. Navigating to the directory in Terminal and doing chmod +x yourscript.sh (replace “yourscript” with the
name of your script) or

2. On Mac: Open Terminal. Type:
chmod +x
...with a space at the end (and do NOT press enter yet).
Then, drag the file you want to change from the Finder and drop it on top of the Terminal window. The file path and
filename should automatically fill in (and you should ensure that there's a space between "+x" and the file path).
Press Enter.

3. On Linux, in your GUI file navigator (e.g. Nemo) right click on File => Properties => Permissions=>
Allow executing file as program

Create a shortcut for your script: Preferences => Keyboard => Shortcuts => Add custom
shortcut ... Give the shortcut a name to match the script then navigate to the “Command” (which is your
script) in the box with the file icon. Click Add. Highlight the new item in the shortcuts dialog and, in the
44 Sometimes there may be a conflict between shortcuts. See this page.
45 There are many resources on the web to help with learning Bash - Some examples:
https://linuxhint.com/30_bash_script_examples/ http://linuxcommand.org/lc3_wss0010.php
46 Three good open-source cross-platform text editors are Geany, Gedit, and jEdit. I also like Smultron.

“Keyboard bindings” below, double-click on the first “unassigned” and use your keyboard to enter your desired
key combination for the shortcut.

InsertUniqueID.sh

#! /bin/sh
xdotool keyup "shift+alt+d"; #send that the user let go of the shift+alt+d keys,
otherwise it interferes with ctrl-v
date '+%Y%m%d%H%M%S' | tr -d "\n" | xsel -i -b; #put Unique ID in the clipboard
xdotool key "ctrl+v"; #simulate a ctrl-v

My assigned shortcut key combination: Shift+Alt+D

InsertTimestamp.sh

#! /bin/sh
xdotool keyup "shift+alt+t"; #send that the user let go of the shift+alt+t keys,
otherwise it interferes with ctrl-v
date '+%Y-%m-%d %H:%M:%S' | tr -d "\n" | xsel -i -b; #put the date/time in the
clipboard
xdotool key "ctrl+v"; #simulate a ctrl-v

My assigned shortcut key combination: Shift+Alt+T

Texpander provided by Lee Blue. Follow his instructions at https://leehblue.com/ubuntu-text-expander/

texpander.sh
#!/bin/bash
# Version: 2.0
# Release: November 24, 2017
# Get window id, pass to getwindow pid to output the pid of current window
pid=$(xdotool getwindowfocus getwindowpid)
# Store text name of process based on pid of current window
proc_name=$(cat /proc/$pid/comm)
# If ~/.texpander directory does not exist, create it
if [ ! -d ${HOME}/.texpander ]; then
mkdir ${HOME}/.texpander
fi
# Store base directory path, expand complete path using HOME environment variable
base_dir=$(realpath "${HOME}/.texpander")
# Set globstar shell option (turn on) ** for filename matching glob patterns on subdirectories of
~/.texpander
shopt -s globstar
# Find regular files in base_dir, pipe output to sed
abbrvs=$(find "${base_dir}" -type f | sort | sed "s?^${base_dir}/??g" )
name=$(zenity --list --title=Texpander --width=275 --height=400 --column=Abbreviations $abbrvs)
path="${base_dir}/${name}"
if [ -f "${base_dir}/${name}" ]
then
if [ -e "$path" ]
then
# Preserve the current value of the clipboard
clipboard=$(xsel -b -o)
# Put text in primary buffer for Shift+Insert pasting
echo -n "$(cat "$path")" | xsel -p -i
# Put text in clipboard selection for apps like Firefox that
# insist on using the clipboard for all pasting
echo -n "$(cat "$path")" | xsel -b -i
# Paste text into current active window
sleep 0.3
xdotool key shift+Insert
# If you're having trouble pasting into apps, use xdotool
# to type into the app instead. This is a little bit slower
# but may work better with some applications.
#
# Make xdotool type RETURN instead of LINEFEED characters
# otherwise some apps like Gmail in Firefox won't recognize
# newline characters.
#
# To use this, comment out line #32 (xdotool key shift+Insert)
# and uncomment the line below.
#xdotool type -- "$(xsel -bo | tr \\n \\r | sed s/\\r*\$//)"
# Restore the original value of the clipboard
sleep 0.5
echo $clipboard | xsel -b -i
else
zenity --error --text="Abbreviation not found:\n${name}"
fi
fi

My assigned shortcut key combination for Texpander: Ctrl+Space
I use Texpander in the same way as I use espanso on the Mac – to insert templates for notes. See Templates
below.

Scripts for Mac
Apple provides many keyboard shortcuts. See, for example, the links below in the section Useful Shortcuts.
Customized shortcuts and scripts will not always work in all applications since there may be conflicts.
You may wish to check to see it Apple’s shortcuts provide what you want. Go to
System Preferences => Keyboard => Shortcuts => Services

Insert Unique ID
Open Automator and go to File => New => Service => Choose
At the top "Service receives selected" scroll down and select "no input"
In the search box next to "Variables" type "run" click and drag "Run Applescript" into the workflow area
to the right.
Copy and paste the red text below to replace
(* Your script goes here *)
on run {input, parameters}
set uiq to do shell script "date +'%Y%m%d%H%M%S'"
tell application "System Events"
keystroke uiq
end tell
return input
end run
File => Save => Save service as: Insert_UniqueID

to save the workflow as a service.

Open System Preferences => Keyboard => Shortcuts =>Services
Locate your service – It should be under "General" toward the end.
Click on the name of your service and click to the right on "none"
Use your keyboard to assign a shortcut.
My assigned keybinding is Ctrl+Cmd+U

Insert Short Date and Time
In Automator File => Open Recent => Insert_UniqueID
Then File => Duplicate
Replace the script from

set uiq to end tell with the script below

set dateString to do shell script "date +'%Y-%m-%d %k.%M'"
tell application "System Events"
keystroke dateString
end tell
File =. Save => Save service as: Insert_Short_Date_Time to save the workflow as a service.
Set your shortcut for this service. Mine is Ctrl+Cmd+T

Generate unique identifier for plain text file names opening in target app
Script provided by Mark Koester47

zettel.sh
#!/bin/bash
#
# Bash script to generate a unique identifier for file name
# Used for a Plain Text Writing, Knowledge or Notes System
#
# Allows for following Options:
# -o: opening file in a target program
# Additional Title or name appended to end of file name
#
# Examples
# ./zettelnote.bash # creates file like 201902111415.md
# ./zettelnote.bash -o # create and open file
# ./zettelnote.bash test # creates file like 201902111415_test.md
file_date=$( date '+%Y%m%d%H%M' )
if

[[ $1 = "-o" ]]; then
TARGET_NAME=${2}
else
TARGET_NAME=${1}
fi
if [[ -z "$TARGET_NAME" ]]; then
filename="$file_date.md"
else
filename="$file_date""_$TARGET_NAME.md"
fi
if [ -f $filename ]
then
echo "File already exists. Skipping."
else
echo "Creating Note File: " $filename
touch $filename
fi
if

[[ $1 = "-o" ]]; then
echo "Opening file"
open -a MacDown $filename

fi

My assigned shortcut key combination – with Quicksilver 48 running: Ctrl+Cmd+W
Click into the title at the top centre of MacDown to add your own text to the title.

Use pandoc to convert .odt files to .md

47 I have borrowed Mark’s zettel_identifier_note_creator.bash which he shared on GitHub Gist.
48 I set QuicksilverQuicksilver and Zotero to start at login: System Preferences => Users and Groups => Login Items

This requires use of the command line and for pandoc to be installed on your system. Open Terminal and
navigate to the dedicated folder where you sent .odt files, as suggested, from Master Document of LibreOffice –
See Plain-text Note-taking with Zotero? below. Paste this script into Terminal.
for i in *.odt ; do echo "$i" && /usr/local/bin/pandoc -s $i -o $i.md ; done
Hit Enter

The Command Line and Bash
Here are a few resources for learning to use the command line:
Beginner
https://programminghistorian.org/en/lessons/intro-to-bash
https://www.educative.io/blog/bash-shell-command-cheat-sheet
https://www.bash.academy/
https://ryanstutorials.net/
https://towardsdatascience.com/basics-of-bash-for-beginners-92e53a4c117a
https://tutorials.ubuntu.com/tutorial/command-line-for-beginners#0
http://linuxcommand.org/lc3_learning_the_shell.php
http://linuxcommand.org/tlcl.php
https://www.tldp.org/LDP/Bash-Beginners-Guide/html/
https://learntocodewith.me/command-line/unix-command-cheat-sheet/
https://www.kendallgiles.com/intro-unix-command-line/intro.html
https://datacarpentry.org/shell-genomics/01-introduction/index.html
Advanced
https://wiki.archlinux.org/index.php/Command-line_shell
https://tldp.org/LDP/abs/html/
https://www.tldp.org/LDP/abs/abs-guide.pdf
https://devconnected.com/advanced-bash-scripting-guide/

Templates

Standalone_Zettel_Template.txt

______________________________________________________________________
Select item link (included in Report):

.................
Compare:

...................................
Related (optionally annotate these)

Notes:

References:

.................
Keywords: #
.................
External links:

.................
Created – Date & Time:
Modified:
Type tags: %%%cjp
Status: - [ ] {EdPhD}

______________________________________________________________________

Annotation_Zettel_Template.txt
______________________________________________________________________
Select item link (included in Report):

Verbatim Quote ends
Citation:
Main Points or Sub-Topics
Paraphrase
Comments
Summary
Quotes
.................
Compare:
...................................
Related (optionally annotate these)
Notes:
References:
.....................
Keywords: #
.....................
External links:
....................
Easy CiteKey:
Created - Date & Time:
Modified:
Type tags: %%%annotation
Status: - [ ] {EdPhD}
______________________________________________________________________

Useful Shortcuts

Zotero
Copy select item links
The Zotero plug-in, Zutilo can copy links from items in your library. In LibreOffice these are clickable and can be
useful during the outline stage of writing. (Note: they are automatically included in generated Reports)
In Zotero: Tools => Zutilo Preferences => Shortcuts Scroll to “Copy select item links” and assign a shortcut.
Mine is Shift+W
Similarly Zutilo provides a customizable script to create a parent item. I use this on standalone notes. My
shortcut is Shift+P

Quick Copy Easy Citekey
Quick Copy is a way to get the Citekey from Zotero in various formats. Cmd+Shift+C or Ctrl+Shift+C
copies the Citekey to the clipboard. Drag and drop also works.
Set the Default Format to Easy Citekey on Mac at Zotero menu => Preferences => Export
On Linux: Edit => Preferences => Export

More Zotero shortcuts at https://www.zotero.org/support/kb/keyboard_shortcuts

Mac
Mac OS X shortcuts here: https://support.apple.com/en-us/HT201236 and here:
https://www.digitaltrends.com/computing/mac-keyboard-shortcuts/

Linux-Mint
Numerous web pages give linux shortcuts for various purposes. Some useful ones can be found here
https://community.linuxmint.com/tutorial/view/45

Plain-text Note-taking with Zotero?
One of Zotero’s limitations is its inability to export notes in plain text. 49 For anyone who has ever experienced
being “locked in” to an app because of its proprietary format, plain-text note-taking is an attractive option. 50
Unfortunately, at the time of writing, to my knowledge, only quasi plain-text note-taking is possible with Zotero.
Zotero allows drag-and-drop of files to its main “Items” pane. You can create a new item and drag a .txt or .md
file onto it and it becomes an attachment to which notes can be added. However these attachments become
part of the database and are no longer plain-text. 51
The Advanced Search in Zotero allows searches to be saved and then a customizable Report can be made
from the saved search. The .md files could be exported (as a concatenated file) in this way. Copy and paste
from the Report.
If you decided to attempt this text based note-taking in Zotero, links can of course be added in Markdown
including links to a url, a resource on your network, or a cross-reference.
Zotero notes can be copied and pasted into your favorite Markdown editor. You can paste the source code
below an extracted annotation in Zotero into the Markdown file to get a clickable link that will take you to the
page in the pdf e.g: <a href="zotero://open-pdf/library/items/X3VQ5RRC?page=1">Popper 2014:1</a> is
rendered as Popper 2014:1
Another option to get your notes sub-collection or saved search from Zotero into multiple plain-text notes is to
use Reports. As described in the section above on Generating Reports of Notes you can generate a report,
customize it to clear the fields you don’t want, paste it into LibreOffice and split it into sub-documents. File
=> Send => Create Master Document. Save the sub-documents in a dedicated folder where you can
use a bash script to convert to .md. 52
However, if convenience and ease of use are important, luckily, the HTML and rtf formats used by Zotero,
although not as portable as plain-text, are also quite portable.

Open-source Plain-text Cross-Platform Note-taking Applications
Org mode Runs within Emacs and its variants (such as Spacemacs). Very versatile, steep learning curve.
Joplin Markdown note-taking and todo app. Uses an SQLite database. Javascript with Electron wrapper.
Zettlr Markdown editor with Zettelkasten for academic writing. Electron, Node.js, CodeMirror.
Zettelkasten 3 Digital slip box, or filing card system based on Niklas Luhmann's Zettelkasten. Java.
QOwnNotes Plain-text markdown notes with (optional) Nextcloud integration. C++ with Qt framework.

49 You can export all notes (incl. parent items) as one plain-text file by Right-clicking to export a collection, a saved
search, or Right-click on one of a selection of items (Ctrl+click to select) as a BibTeX file using the Better BibLaTeX
export. Standalone notes will need to have a parent item.
50 Zotero’s code is open source. It has about 30 export options. BibTeX export is enhanced by Better BibLaTeX.
Note: The Zotero export documentation says: Import/export is not recommended for transferring entire Zotero libraries
between systems, and, if you use Zotero's word processor plugins, links to Zotero items from existing word processor
documents will be lost after an export/import. See the Maintenance section above for backups and transferring.
51 The original remains in its own folder but is not updated by changes made in Zotero.
52 See above for script to convert .odt files to .md.
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